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Background information 
Adobe InDesign is a desktop publishing and design software used to create materials such as posters, flyers, 
brochures, magazines, newspapers, books, and other forms of documentation. Its strengths are its control and 
versatility in constructing page layouts and depth of features in modifying type.  

This intermediate workshop is designed to provide you with the skills and knowledge needed to build 
professional documents using advanced layouts and styles. Furthermore, you will also learn how to apply basic 
and intermediate typesetting and typography best practices to your text.  

Required skills 
Before beginning, the following skills and workshops are required:  

• Introduction to InDesign CS5 
• Basic-Intermediate knowledge of word-processing terminology 
• Basic computer navigation skills and knowledge 

Agenda 
• Creating, modifying, and applying paragraph and character styles 
• Creating and applying master pages 
• Creating and applying page numbers.  
• Basic typography terms and principles 
• Advanced text formatting. 
• Building and using grids. 

Creating and Applying Styles 
Similar to Microsoft Word, styles are a collection of formatting properties that can be applied to text with a 
single click. Styles determine the line spacing, indentation margins, hyphenation, and justification properties, 
among other things, of a body of text. When a style is changed or modified, all text to which the style has been 
applied to will be automatically updated. In InDesign, you can use existing styles or create your own. 

Paragraph styles 
By default, each new document is formatted with the default Basic Paragraph style. Though you can modify this 
style or create new ones, you are unable to delete it. 

1. Select Paragraph Styles in the application panels. Or select Type > Paragraph Styles in the file menu.  
2. To base your paragraph style off an existing style, right-click the style and select Edit “[StyleName].”  
3. To create a new style, select the Create New Style icon on the bottom of the panel window.  
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4. Double-click your selected style to reveal the Paragraph Style Options window. The Paragraph Style 
Options window contains many advanced settings. For this intermediate workshop, we will focus on a 
few of those settings, many of which we will revisit. 

 

• General— from this menu, you can choose to base your style off an existing style or assign a 
shortcut key to it for quick access. It is recommended that you assign names to your styles. 

• Basic Character Format— allows you to assign common text properties such as Font Family, 
Style, Size, Case, Position, among many other options.   

• Indents and Spacing—set properties such as text alignment, indent margins and line spacing.  
• Hyphenation—establishes word hyphenation properties and rules.  
• Justification—sets the justification properties of your text. This menu will also allow you to 

modify your style’s word and letter spacing. 
• Span Columns—allows you to span your paragraph or section of text across multiple columns 

automatically, such as seen in magazine or newspaper layouts.  
• Drop Caps and Nested Styles—you can apply a style to the drop-cap character (the initial 

character) of any paragraph from this settings screen. You can also specify formatting for a 
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specific range of characters or lines within an existing style. Drop caps and nested styles are 
especially useful for beginning or heading a paragraph.    

• Bullets and Numbering—determines the formatting and style for any bullets or numbered lists 
that you insert into your document.  

5. When you are finished in setting the format and properties of your style, select OK.  

Applying styles 
1. To apply a style to a section of text or text thread, select your chosen text frame with the Selection tool. 

Then select the style in the Paragraph Styles panel.  
• Any text within the frame or linked to it will update itself automatically.  

 

 

Activity 1: Create a Paragraph Style based on your own desired settings. Then insert a block of text and 
apply your newly created style to it.   

Inserting drop caps 
The use of a large letter, word, or phrase, to make the start of a section of text is known as a drop cap. Drop 
caps also indicate important passages, guide readers through the layout of a page, and function as a decorative 
element. More commonly, characters are dropped one or two lines (the character, word, or phrase, extends 
across the vertical height of one or two lines of text). 

1. To insert a drop cap, with the Type tool, select and highlight your chosen letter, word, or phrase.  
2. With the text selected, select the Paragraph panel in the application panel.  
3. In the Drop Cap Number of Lines field, input the number of lines that you want your text to drop.  
4. If desired, in the Drop Cap One or More Characters field, input the numbers of characters that you want 

to drop.  
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In the first of the below examples, the drop cap is dropped by three lines and four lines respectively.  

 

Activity 2: Apply a drop cap to the beginning character , word, or phrase of your section of text. Adjust 
the amount of lines and characters that the drop cap extends over.  

Inserting Multiple Pages 
One of InDesign’s primary uses is in the arrangement and management of multiple page spreads, such as those 
found in book or magazine publications. Pages are arranged visually in the Pages panel.  

1. To access the Pages panel, select it from the application panel. If the Pages panel is not visible, you may 
need to select an appropriate Workspace from the Workspace switcher menu.  

2. With the Pages panel open, click the Create New Pages icon at the bottom of the panel. 
• You can also right-click inside the Pages panel and select Insert Pages from the right-click menu.  
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Creating and Applying Master Pages 
A Master Page functions as an overall template or preset that can be applied to many different pages at once. 
All frames and objects (including page numbers, headers, footers, and grids) that are created on a Master Page 
will appear on all pages it has been applied to. Furthermore, any changes that you make to your Master Page 
will also be automatically updated on its associated pages. You can create as many Master Pages as needed. 

There is no limit to the amount of master pages that your document can contain.  

New master pages 
1. With your document open, select Pages in the application panel. The A-Master template will serve as 

your default master page.  
2. You can also create new or delete master pages by right-clicking the master page and selecting New 

Master or Delete Master Page. 
3. In the dialogue box, specify the identifying Prefix for your master page, a Name, if the new master is 

based on a previous one or not, and Number of Pages in the spread.  
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Master pages from existing pages 
You can also easily create master pages by using existing page formats or layouts.  

1. In the Pages panel of the application panels, drag a page from the Pages section to the Masters section. 
InDesign will then automatically assign it a suitable Prefix.  

2. You can also right click your chosen page in the Pages section and select Save As Master.  

 

Apply your master page 
In order to apply your master page, right-click the master page and select Apply Master to Pages, then indicate 
the pages you wish to apply the master to in the dialogue box.  

 

Activity 3: Insert additional pages to your document. Then apply your style to the default A-Master page 
or a newly created master page. Create a second or new master page and apply a different style to it. 
Apply this style to a designated page range.  

Page Spreads and Numbering 

Page numbers can be easily added to your document through the use of master pages. When master pages are 
applied to your documents, page numbers are automatically updated.  
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1. In the Pages panel, select your master page by double-clicking it.   

 

2. Create a text frame large enough to contain your longest page number and any other text you wish to 
include. Then position the text frame where you want the page number to appear.  

• For a document with facing pages, create separate text frames for right and left master pages.  
3. In the file menu, select Type > Insert Special Character > Markers > Current Page Number. 

• You can also right-click your inside your text frame and select Insert Special Character > Markers 
> Current Page Number in the cascading menu.  

 

4. Then apply the master page to the pages which you want to be numbered.  

 

Changing the page number style 
1. In the Pages panel, select the page where you want to modify the numbering style or format.  
2. In the file menu, select Layout > Numbering & Section Options.  
3. Choose the format or style that you want and click OK.  

Activity 3:  Create text frames for page numbers in your master page. Then insert current page markers 
into these text frames and apply the master pages to your document. Change the location of your page 
numbers in the master page and note the changes made to the rest of your document.  
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Basic Typography Terms and Principles 
Typography refers to the technique of arranging type (text) in order to make it visually appealing or 
communicable. This process involves the selection of typefaces (fonts), size, line length, leading (line spacing), 
the spacing between groups of letters (tracking), and the spacing between pairs of letters (kerning).  

Like photography and illustration, typography is a vital part of media communications, especially in mediums 
which focus on language such as magazines, advertising, and websites. 

The following images are examples of effective typography: 

 

Note the different ways in which the text interacts with both the viewer and its associated visuals in 
communicating a message or meaning. What happens when these images are combined? 

As with all design processes, there are various elements to consider. 

Things to Consider When Designing Your Document1 
The following information is intended to serve as a guide for designing your document.  

Serif and San-serif typefaces 
The choice between serif and san-serif typefaces is one of the more fundamental decisions in document and 
web design. Depending on the medium and intended use, there are distinct advantages and disadvantages. 

• Serif—contains small trailing marks, known as serifs, at the ends of characters or symbols. Common serif 
fonts are Garamond, Georgia, and Times New Roman. Serif typefaces are typically used for body text in 
lengthier documents such as books, newspapers, or magazines, because it is considered by many to be 
easier to read. Due to the way that text is produced on electronic devices, it is not common to use serif 
typefaces for digital media.  

                                                           
1 http://www.smashingmagazine.com/2009/08/20/typographic-design-survey-best-practices-from-the-best-blogs/ 
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• Sans-serif—does not contain any trailing marks at the ends of characters or symbols. Common sans-serif 
typefaces are Arial, Tahoma, and Verdana. For print media, sans-serif typefaces are typically used for 
headlines or titles, not body text. In contrast to serif typefaces, sans-serif typefaces are very common in 
digital media due its readability on digital screens.  

 

Popular typefaces 
• 60% of major websites use sans-serif typefaces for headlines.  
• Only 34% use serif typefaces for their body text.  
• The most popular serif typefaces for headlines are Georgia and Baskerville.  
• The most popular serif typefaces for body text are Georgia and Times New Roman. 
• The most popular sans-serif typefaces for headlines are Arial, Helvetica, and Verdana. 
• The most popular sans-serif typefaces for body text are Arial, Verdana, and Lucida Grande.  

Background colors 
Pure white is the most dominant background color for body text across all design media. In addition, high 
contrast pure black and pure white is rarely used and for the majority of media, the color of text is slightly 
lighter than pure black. The primary focus for body text is readability with white being the standard background.   

Average fonts sizes depending on use 

Headlines 

• The most commonly used font sizes for document headlines range from 13.5 to 24 point font. Within 
this range, 13.5-14.5 and 18-20 point sized fonts were the most popular. Usage of certain sizes depends 
on the design and intended use of your document. With the increasing resolutions of modern display 
devices, the usage of larger point sizes is increasing.  

Body text 
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• Font sizes for body text in electronic media range from 9 and 10.5 point sized fonts. In most scenarios, 
typesetting and involve ample use of white space, leading, and padding.  

 

General guidelines 
The following guidelines serve as a reference for common practices in web and electronic document design. 

• Serif and sans-serif fronts are commonly used for body and heading text, though san-serif fonts are 
generally more popular.  

• Common typefaces for headlines are Georgia, Arial, and Helvetica. 
• Common typefaces for body text are Georgia, Arial, Verdana, and Lucida Grande. 
• The ratio between header and body text font sizes is 1.96. 
• The average line height for body text (leading) is 1.48. 
• The average space between paragraphs is .754 
• Body text is usually left-aligned and links are either underlined or highlighted with bold or color.  

More detailed information can be found at:   

http://www.smashingmagazine.com/2009/08/20/typographic-design-survey-best-practices-from-the-best-
blogs/ 

Advanced Text Formatting 
Kerning is the process of adding or subtracting space between individual letters or characters. Similar to kerning, 
tracking is the process of adding or subtracting of space within a word or block of letters.  



IRT: Intermediate InDesign 
 

 (Version 6: 07/05/2013) 12 
 

Kerning 
There are two automated settings for text kerning: metric and optical. The default setting for InDesign is metric, 
which determines kerning amounts based on predetermined values embedded within the typeface. Optical 
determines the kerning amount based on the shapes of adjacent characters. This is useful if you are combining 
different fonts or sized text on the same line.  

 

1. With the Type tool selected, click in the space between two letters inside your text frame.  
• You can also do the same by selecting a pair of letters with the Type tool. 

2. In the Character panel or in the Control panel, locate the Kerning menu . 

 

3. In the Kerning menu, you can select Metric or Optical. You can also manually set the kerning amount 
or turn kerning off by setting it to 0.  

Tracking 
1. Select a section or block of text using the Type tool.  
2. In the Character panel or in the Control panel, locate the Tracking menu .  
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3. You can manually set the tracking amount from this menu or turn it off by selection 0.   

Activity 4:  Insert or type a line of text. Modify the spacing properties of your text by adjusting the 
kerning and tracking settings.   

Justification 
InDesign allows for the setting of justified text, text that is aligned to both right and left margins. Properly 
formatting justifying text involves the stretching and compressing of line space (kerning and tracking). It also 
entails the modification of hyphenation settings, if hyphenation is used. The last line of a justified text is 
considered separate from the rest of the body of text.  

If not properly tracked and kerned, setting justified text may present some issues:  

• Loose lines—lines in which large gaps or spaces appear between only a few words.  
• Rivers—lines of text in which the space between words or characters appear right above one another.  

 

1. To justify your text, select or highlight your section of text with the Type tool. With the text now 
selected, select one of the justification rules located in the panel underneath the Workspace 
switcher in the Control Panel. The following options are available:  
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• Justify with last line aligned left. 
• Justify with last line aligned center. 
• Justify all lines.  

 

H&J Violations 

It may be help to enable the showing of H&J Violations in your document. H&J violations are what InDesign 
considers as hyphenation and justification issues which result in improper line spacing, such as the appearance 
of loose lines or rivers. Being able to see H&J violations will make kerning and tracking corrections easier.  

1. To enable H&J Violations, in the file menu, select Preferences > Composition. Now with the 
Composition window open, under the Highlights heading, check H&J Violation.  

 

2. All H&J Violations will be highlighted in yellow. Mild or light violations will be represented by lighter 
shades of highlighting.  

 

3. A variety of methods can be used to correct H&J violations: 
a. Select or highlight the highlighted section of text and modify its kerning and tracking values. 
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b. Modify the Hyphenation settings of your document in the Paragraph Style Options.  
• The following Hyphenation settings are common for print documents. Only lengthier 

words are hyphenated and there is only hyphen per row of words.  

 

c. Adjust the size of your text frame, text frames, or font size.  
d. Edit the contents of your text.  
e. Modify the Word Spacing, Letter Spacing, and Glyph Scaling values in the Paragraph Style 

option. These settings are dependent on the typeface, column width, text frame size, and 
the documents intended use.  

• The below settings are common justification settings for text arranged across 
multiple columns.   

 

Activity 5:  Enable the viewing of H&J Violations in your document. Insert a paragraph length section of 
text and justify it (note the highlighted violations in your text). Then attempt to resolve these violations 
using the outlined methods.  

Building and Using Grids 
Grids serve as guides in helping designers systematically organize the elements of their document. Almost all 
newsletter, magazine, newspaper, or website layouts feature some form of a grid system, which gives the 
viewer or reader a sense of order and structure.  
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InDesign features a semi-automated process that will allow you to quickly implement your own design grid.  

Gridify 
In creating your document, it may be helpful to show the Document Grid in your Workspace. In the file menu, 
select View > Grids & Guides > Show Baseline Grid.  

1. To create a grid using objects, select the object with the Direct Selection tool and drag the object while 
holding the Alt key. This will create a clone of the object.  

2. While dragging, press the arrow keys to grid the objects into rows or columns.  
• Due to the distance of the keys, it is advised to press the Alt key on the right hand side of your 

keyboard.  



IRT: Intermediate InDesign 
 

 (Version 6: 07/05/2013) 17 
 

  

3. To create a grid with threaded text frames, click and drag with the Type tool. While dragging, press the 
arrow keys to create your grid. Release the mouse button to create your gridded text frames. If your text 
frame has already been created, you can “gridify” it using the method outlined in step 1.  

   

4. Grids can also be created the master page and applied to the rest of your document.  

Activity 6:  Using the Gridify tool, construct your own grid. Then insert text into that grid. Apply this grid 
to a master page to be used as a template.  
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